No database tables browser window with Informix 12.10 ( current version)

  • updated
  • Completed

I am testing your tool that looks cool on the current version of Informix, which is 12.10 FC4

I ran againtst the 32/64 ODBC driver that I solved by installing the 32bits Informix CSDK. I can now connect successfully by clicking on 'connect'. No error message appears.
If I indicate a non existing database name, I get a 'database does not exist' error, meaning that in some way the connection is being done when connecting to the right db name.

The thing is that I have only the 'Queries' tab appearing after connection, and no 'Tables' tab to be expendend.

Am I missing something or am I the first person to test this ?
Any solution ?

Eric Vercelletto
Board of Directors, International Informix Users Group
 IBM Champion
Vercelletto Eric
I obviously set Informix Version 11 or higher in the Informix version :-)

Possibly all user tables in your database are placed in the Informix schema which is marked as system schema. FlySpeed SQL Query doesn't show system database objects by default, but you can turn this option off in Connection Properties dialog. Click on the "More options" button to see the Advanced tab in this dialog.
This problem is fixed now without setting the "Show system objects" option.